Daniela und Frank Leyhe GbR
Alte Hellersdorfer Straße 141
Berlin
Germany / Berlin / Berlin 12629
Phone: +49 (0)30 889 454 24

CT Security System 9.3.3

CT Security System 9.3.3

26 Beiträge / 0 neu
Letzter Beitrag
Frank
Bild des Benutzers Frank
CT Security System 9.3.3

Informationen zur neuen Version.

  1. Bugfix in der ACP Templates cachen Datei - Fehlermeldung.
  2. Mail Versand aller CT Informationen abgesichert.
  3. Antivirus Scanner erweitert (Signaturen) und eine neue Überprüfungsregel eingebunden.
  4. PHP Quellcode Scanner zwei neue Überprüfungsregeln eingebunden.
  5. Shell Scanner eine neue Überprüfungsregel eingebunden.
  6. Welcome Seite im ACP auf Grund der neuen Homepage - Download Link und Hinweistext geändert.
  7. Virus Signaturen insgesamt für alle Viren-Scanner erweitert.
  8. Linkblock erweitert.
  9. FormSpam Schutz erweitert.
  10. Abwehrsignaturen erweitert - wichtige Anpassung für PHP5.4 vorgenommen.
  11. Block-Information an einer Stelle die Ausgabe verbessert. (Code Anpassung)
  12. Neue Funktion - Prefetch verbieten
  13. 1 Images hinzugefügt.
  14. Updateanleitung erstellt.

Aktuelle Lizenznehmer können ab sofort die aktuelle Version über "Mein Konto" - "Verlauf - Datei downloads" - "Hier klicken um Ihre Downloads zu sehen" herunterladen. Der Downloadlink ist derselbe wie bei Ihrer Bestellung. Alle anderen können diese Version für Woltlab wbb2 im Shop bestellen.

 

Bearbeitet von: Frank an 04.02.2012 - 15:15
Frank
Bild des Benutzers Frank
CT Security System 9.3.3 - Bugfix

In der Datei acp/ct_acp_tpl.php gibt es einen kleinen Fehler. Dieser wurde so eben im Download Paket behoben.

Mondwolf
Bild des Benutzers Mondwolf
ACP Fehler

...jetzt hat es mir wie schon einige Male das Acp verhagelt. Nicht alle Seiten, aber sehr viele.
Passierte nach dem ACP-Templates cachen.

LG vom Wolf

 

P.S. unten rechts in der Ablage zeigt er mir:

Parse error: syntax error, unexpected ';' in /www/htdocs/w007d2b8/wbb2/acp/misc.php(162) : eval()'d code on line 402

Frank
Bild des Benutzers Frank
Steht ja in der Meldung. In

Steht ja in der Meldung. In der acp/misc.php wird in Zeile 162 eine TPL aufgerufen und in dieser Template in Zeile 402 befindet sich ein Fehler. Da steht dann ein ; drinnen, was da nicht hingehört. Das einmal prüfen. Ich vermute einfach mal das in dem Ordner acp/template/ eine PHP Datei vorhanden ist. Kann das sein?

Mondwolf
Bild des Benutzers Mondwolf
... ne, ist nicht. Wir hatten

... ne, ist nicht. Wir hatten das schon mal, ist schon länger her. Hab mal ein Bild angehangen.
 

LG Jürgen

Edit: Bild entfernt - kann hier jeder sehen. Lieber vorher sensible Infos wie z..b. Domain unkenntlich machen.

Frank
Bild des Benutzers Frank
Kann mich erinnern. Hab Bild

Kann mich erinnern. Hab Bild entfernt (siehe Dein Eintrag). Und irgendwie gab es damals auch eine Lösung vom ganzen - glaube ich zu mind. Kannst mir ja mal FTP und ACP Zugang per Email oder Nachricht (PN) geben.

Mondwolf
Bild des Benutzers Mondwolf
... hast ne PN ;-)

... hast ne PN ;-)

Frank
Bild des Benutzers Frank
Fehler behoben, lag an einem

Fehler behoben, lag an einem Fehler in einer acp/templates/.htm Datei die von einem anderen Hack stammte. Rest per PN. smiley

Mondwolf
Bild des Benutzers Mondwolf
So isses...

... bist halt der Beste !

Vielen Dank und Gruß vom Wolf

Gnom
Update Ohne Probleme DANKE

Update Ohne Probleme

 

DANKE

 

Hab doch noch eine kleinigkeit

 

Wenn ich einen neuen Admin eintragen möchte in die CT User/Passwort verwalten (.htaccess)

Speichert er mir die daten nicht

 

Ebenso kann ich nicht löschen

Hab die anleitung nun mehrfach gelesen nur finde ich da iwi nicht den passenden punkt wo ich evtl einen fehler gemacht habe

 

PS: wenn ich meine jetzige vom Server nehme und eine neue erstellen möchte geht dieses auch nicht

Frank
Bild des Benutzers Frank
@all hier liegt ein Problem

@all hier liegt ein Problem mit den Ordner Rechten vor. Wird intern geklärt und in Zukunft entweder ein Hinweis in der CT htaccess stehen oder noch besser eine Automatik enthalten sein.

Madden
Bild des Benutzers Madden
Neue Funktion - Prefetch verbieten

Hallo Frank

 

Könntest du mal ein paar Worte über diese neue Funktion verlieren ?

Neue Funktion - Prefetch verbieten

 

 

Danke....

Frank
Bild des Benutzers Frank
Gut erklärt wird es hier:

Gut erklärt wird es hier: Prefetch

 

Man kann da Pro & Kontra lesen. Diese Funktion kann so oder so gesehen werden. Bleibt also jedem selber überlassen, ob man diese Funktion nutzen möchte oder nicht.

Madden
Bild des Benutzers Madden
ok danke , das werd ich mir

ok danke , das werd ich mir anschauen...

 

 

mfg M.

Halifax206
Hallo, ich habe ein kleines

Hallo, ich habe ein kleines problem wenn ich im acp und dann auf  ct acp schutz klicke, erhate ich nur eine weiße seite. einzigste was ich gemacht habe das reine wbb an sich auf php 5.3 umgebaut, am eigentlichen ct habe ich nic gemacht.

 

LG Markus

Frank
Bild des Benutzers Frank
hmm schwer zu sagen,

hmm schwer zu sagen,

 

versuche mal folgendes, folgende Dateien in der Reihenfolge hoch laden (aus der aktuellen 9.3.3):

 

1.) acp/ct_settings_acp.php

1.1) dann testen ob der Aufruf geht..

 

2.) acp/lib/ct_options_acp.inc.php umbenennen in z.b. ct_options_acp.inc.php.old

2.1) dann diese neu hoch laden.

2.2) testen ob der Aufruf geht.

Halifax206
hallo Frank, ich habe das

hallo Frank, ich habe das ebend mal getestet

 

bisher  aber immer noch die weiße seite

 

irgendwie schwirtt mir was im hinterkopf herum das wenn man in irgendein code in die aufzurufende datei  gibt, dass dann stat der weißen seite irgendeine fehlermeldung erscheint.

 

Aber wie und wo genau weiß ich nicht, auch was fürn code weiß ich nicht mehr.

 

LG Markus

Frank
Bild des Benutzers Frank
In solchen Fällen wurde

In solchen Fällen wurde Serverseitig die Fehlermeldung abgeschaltet. Dient der Sicherheit. Um aber nun Fehler zu finden und man nicht an die Serverlogs kommt macht folgendes:

Füge in beiden global.php nach dem <?php folgende Zeilen ein:

ini_set('display_errors', 1);
error_reporting(E_ALL);

Falls das nicht geht, nimm nur die zweite Zeile, dann zeigt PHP die Fehlermeldungen an.

 

Steht in der anleitung/tipps.htm - Kapitel 1.3 und nun auch hier. wink

Halifax206
so

so

 

da steht nun

Fatal error: Call to undefined function ct_alt_stat() in /pages/09/42/d0008154/home/htdocs/gamescafe/acp/ct_settings_acp.php on line 122

 

in der zeile 122 wird die lib/ct_options.inc.php aufgerufen

 

habe sie nochmal neu aus der 9.3.3 hochgeladen aber immer noch das gleiche problem

Frank
Bild des Benutzers Frank
Diese Funktion ist für die

Diese Funktion ist für die HOST Erkennung. Aus irgendwelchen Gründen wird diese nun bei Dir nicht mehr aus der Funktions Datei eingelesen.

Ich schreibe Dir kurz eine Nachricht, zum testen einer evtl. Lösung.

 

Halifax206
ok danke dir

ok danke dir

Frank
Bild des Benutzers Frank
@all die Lösung wird in der 9

@all die Lösung wird in der 9.3.4 enthalten sein. Sollte jemand das selbige Problem haben bitte kurz Nachricht bis dahin an mich.

Gnom
So nun  hab ich doch noch

So nun  hab ich doch noch eine Frage

 

Flood Seitenaufrufe (Anzahl der Seitenaufrufe pro Flood Zeit - Standard: 55)

Wenn ich z.b einen hack einbaue Normalen Templates cache danach die ACP Tpls cache fliege ich immer raus ( werde geblockt )

 

nun habe ich mit den werten etwas gespielt aber entweder kam sofort der block oder halt wie vorher

zurzeit schalte ich das teil immer ab und danach wieder an

kann mir jemand mal verraten wie er es eingesstellt hat ?

 

Frank
Bild des Benutzers Frank
Beim ACP TPL cachen, wirst Du

Beim ACP TPL cachen, wirst Du immer rausfliegen, wenn da der Flood Schutz an ist. Der Cache wird so rasend schnell durchgeführt das man da keinen sinnvollen Eintrag vornehmen kann. In so einem Fall dann immer vorher Flood Schutz aus und nach dem cachen wieder an.

 

Was man evtl. machen könnte ist, das man über die CT ACP Template cachen eine Funktion einbindet die den Flood Schutz deaktiviert.

Tappi
In dem kinderheim-oase Forum

In dem kinderheim-oase Forum bekam ich folgendes von einer Userin mit Adminrechten:

 

Hallo,

Bekomme Fehlermeldung
Zugriff blockiert / Access blocks
Das Sicherheitssystem hat den Zugriff auf diese Seite blockiert.

Sollten Sie der Meinung sein das diese Blockierung nicht gerechtfertigt ist,
informieren Sie bitte den Board Administrator, damit das Problem gelöst werden kann.

ist auch in der Shoutbox

portal kann ich auch nicht aufrufen

 

 

In dem Forum war vorher noch kein CT drin, das Forum gibt es erst seit ein paar Wochen. Ich komme ohne Probleme rein auch einige andere User, sie ist bis jetzt die einzige die Probleme hat. Woran kann das liegen?

Frank
Bild des Benutzers Frank
Das Problem steht in der Log

Das Problem steht in der Log Datei.

 

CT Log Anzeigen. Von der Userin bräuchte man dann noch die IP, um zu vergleichen welcher Eintrag das in der Loganzeige ist.

 

Diese Infos dann per Nachricht (PN) oder eMail an mich, weil hier wäre es ja ungünstig.

Benutzeranmeldung

Um automatisierten Spam vorzubeugen lassen Sie dieses Feld leer.

Counter

  • Site Counter:1,422,140
  • Besucher:
    • Heute:108
    • Woche:1,810
    • Monat:10,249

Social