Daniela und Frank Leyhe GbR
Alte Hellersdorfer Straße 141
Berlin
Germany / Berlin / Berlin 12629
Phone: +49 (0)30 889 454 24

CT Security System 9.3.1

CT Security System 9.3.1

44 Beiträge / 0 neu
Letzter Beitrag
Frank
Bild des Benutzers Frank
CT Security System 9.3.1

Information zur neuen Version 9.3.1:

  1. PhpSysInfo auf Version 3.0.15. aktualisiert.
  2. BugFix und neue Funktion (HoneyPot IP Ausnahme) in der Blocker Datei vorgenommen.
  3. BugFix Mail Falle - Blockmeldung wurde nicht ausgegeben.
  4. Bereinigung in der BadBotFalle - Überflüssige Einträge entfernt und einen kleinen Fehler (Frommail - Hinweis) behoben.
  5. Anti Shell Scanner - Überflüssige Einträge entfernt.
  6. PHP Scanner - Überflüssige Einträge entfernt.
  7. Antivirus Scanner - Überflüssige Einträge entfernt. Neue Funktionen von CT Sec. Sys. berücksichtigt.
  8. Proxy Erkennungen verbessert.
  9. Bugfix in der Admin - Blocker Datei.
  10. Etliche Icons im Menü von CT Sec. Sys. ausgetauscht.
  11. Neue Funktion: Sicherheitscheck der Einstellwerte der php.ini
  12. Prüfsummen Check - Überflüssige Einträge entfernt.
  13. Log Anzeige - Überflüssige Einträge entfernt. Kleinere Design Änderungen.
  14. PHPInfo - Kleine Textänderung und Domain in der Verlinkung geändert.
  15. PortCheck - Kleine Code Änderung.
  16. Einstellseite für den öffentlichen Bereich - Neue Menüeinträge vorgenommen.
  17. Einstellseite für den Admin Bereich - Neue Menüeinträge vorgenommen.
  18. White-/Blacklist Anzeige - Überflüssige Einträge entfernt. Kleinere Code Änderungen.
  19. Siteguard - Kleinere Code Änderungen.
  20. htaccess Generator - Kleinere Code Änderungen.
  21. BlockInfo - Pfade geändert. Kleine Korrektur bei der Email Ausgabe.
  22. FormSpam Schutz - Neue Signaturen eingebunden.
  23. Neue Signaturen und neuen Malware-Schutz eingebunden.
  24. Honeypot - Prüfung Proxy geändert. Neue Honeypot Variante hinzugefügt. (Im CT - öffentlichen Einstellbereich auswählbar)
  25. Linkblock erweitert.
  26. In den Optionen von CT alle Menüeinträge, um die neuen Funktionen erweitert.
  27. Footeranzeige - Linkadresse geändert.
  28. Update Anleitung erstellt. Die Umstellung auf PDF Format wird für die wbb2 Version mit der nächsten Version folgen.
  29. Hinweis: Downloadlink im ACP auf der Welcome Seite wird mit der Version 9.3.2 geändert.

Aktuelle Lizenznehmer können ab sofort die aktuelle Version über "Mein Konto" - "Verlauf - Datei downloads" - "Hier klicken um Ihre Downloads zu sehen" herunterladen. Alle anderen können diese Version für wbb2 im Shop bestellen.

 

Bearbeitet von: Frank an 08.01.2012 - 17:45
Madden
Bild des Benutzers Madden
Update

Hallo Frank , schön das es weiter geht (ich hoffe doch)

 

Eine kurze Frage zum Update

Bei mir läuft noch die Version 9.2.0 , um ein Update zu machen bräuchte ich ja die

alte Version 9.3.0. Gibt es noch einen Zugang für die alten Versionen ?

 

 

gruss M.

Frank
Bild des Benutzers Frank
Hallo Madden,

Hallo Madden,

 

ja geht mit Hochdruck wieder weiter. Die Umstellung geht dann wie folgt. Aus der aktuellen Datei die anleitung/update/

  1. update_9_2_0_auf_9_3_0.txt
  2. update_9_3_0_auf_9_3_1.txt

durch gehen. Punkt 1. Weil es da manuelle Änderungshinweise gibt. Wenn Du danach vorgehst klappt alles ohne Probleme.

Madden
Bild des Benutzers Madden
OK  werd ich machen & Danke

OK  werd ich machen & Danke für die schnelle Antwort... Wink

Frank
Bild des Benutzers Frank
Gerne

Gerne Smile

Cyberstar0
Bild des Benutzers Cyberstar0
Juhu

Juhu

 

Seit kurzem bekomme ich manchmal die meldung das es nen fehler in der class_parse.php gibt. Manchaml in der SB oder zb auch weim pn schreiben. jenachdem.Leider hab ich ich mir die net kopiert arg... 

Hier mal die meldung aus dem error log:

PHP Fatal error: Cannot redeclare makehreftag_anonym() (previously declared in /srv/www/vhosts/cybisgameportal.de/httpdocs/GamesForum/acp/lib/class_parse.php:750) in /srv/www/vhosts/cybisgameportal.de/httpdocs/GamesForum/acp/lib/class_parse.php on line 764

 

der teil dort scheint vom ct zu sein. daher hier meine frage was das sein kann.

 

Hier die entsprechende zeiel: (das fettmakierte ist zeile 750)

function makehreftag_anonym($url, $name, $target = '') {
        require("./acp/lib/ct_options.inc.php");    
    if ($umleitung_option == 0) {
    return "<a href=\"".$url."\"".(($target != '') ? (" target=\"".$target."\"") : ("")).">".$name."</a>";
    }
    if ($umleitung_option == 1) {
    return "<a href=\"http://anonym.to/?".$url."\"".(($target != '') ? (" target=\"".$target."\"") : ("")).">".$name."</a>";
    }
    if ($umleitung_option == 2) {
    return "<a href=\"http://urly.de/?".$url."\"".(($target != '') ? (" target=\"".$target."\"") : ("")).">".$name."</a>";
    }
    if ($umleitung_option == 3) {
    return "<a href=\"ct_redir.php?url=".$url."\"".(($target != '') ? (" target=\"".$target."\"") : ("")).">".$name."</a>";
    }
}

 

lg

basti

Frank
Bild des Benutzers Frank
Die Meldung besagt das diese

Die Meldung besagt das diese 2 Mal gleichzeitigt geladen werden will.

 

Probiere einmal aus die Zeile:   require("./acp/lib/ct_options.inc.php");

Zu ändern in:  require_once("./acp/lib/ct_options.inc.php");

 

Ansonsten wäre noch möglich das der Funktionsname selber evtl. noch ein 2tes Mal da drinnen steht? makehreftag_anonym

 

Oder das die class_parse.php evtl. durch die SB bzw. die PN per include bzw. require statt per include_once bzw. require_once eingebunden wird.

Cyberstar0
Bild des Benutzers Cyberstar0
hallo Frank.

hallo Frank.

So ich hab das nunma geändert in -->require_once("./acp/lib/ct_options.inc.php");

Die funktion makehreftag_anonym hab ich nicht nochmal in der php gefunden.

Dann heißt es jetzt erstmal weiter beobachten Smile

Sollte es immer noch auftreten meld ich mich wieder Smile

lg

Basti

Gnom
Hallo

Hallo

hab da nochmal ne etwas dumme frage zur htaccess datei im root

 

wein forum liegt im ordner html/wbb2

 

aufgerufen wird es aber www.meinedomain.de

 

muss ich da jetzt das wbb2 mit rein schreiben oder nicht ?

 

also müssen die einträge so aussehen

Redirect /wbb2/acp/cts_blocker.log  http://www.meine domain.de

oder so

Redirect /acp/cts_blocker.log  http://www.meine domain.de

Frank
Bild des Benutzers Frank
Dann nicht, da die htaccess

Dann nicht, da die htaccess Datei dann auch in den Ordner wbb2/ muss. Die Domain würde die htaccess Datei im Ordner html/ ignorieren.

Tappi
Hallo ich habe bei mir im

Hallo ich habe bei mir im Forum noch  CT Security System Pre 7.0.1: © 2006-2007

Im ACP steht Verwendte Abwehrsignatur: 9.6.35.949104 | Aktuelle Signatur: 9.6.35.954090

Wie und was muss ich nun machen um die neue Version zu bekommen?

Und jap ich freue mich auch das es endlich weiter geht Smile

Frank
Bild des Benutzers Frank
@Tappi

Hallo Tappi,

 

Links in den Shop gehen. Dort auf CT Security System klicken und dann bis nach unten scrollen. Dort auf Seite 2 kannst Du dann die neue Version bestellen. smiley

Tappi
Gibt es denn dann auch eine

Gibt es denn dann auch eine Anleitung um von dem gaaaanz alten auf das neue zu updaten? Oder muss ich das alte erst ganz ausbauen und dann das neue einbauen?

 

Danke schon mal

Gruß Tappi

Frank
Bild des Benutzers Frank
Also hier kann ich nur raten,

Also hier kann ich nur raten, altes ausbauen.

Dann lade Dir die aktuelle 9.3.3 und installiere es. Es gab z.b. Datei oder Ordnernamen Umbenennungen.

Tappi
Ok danke dir erstmal, hmm ich

Ok danke dir erstmal, hmm ich hoffe ich finde alles wieder damit ich alles gelöscht bekomme, da gab es doch auch Dateiänderungen, hast du denn für meine Version noch eine Anleitung damit ich weiß wo ich überall hin muss zum ausbauen?

Frank
Bild des Benutzers Frank
Ja hab ich. Ich schicke es an

Ja hab ich. Ich schicke es an Deine eMail Adresse. mail

Tappi
Super ich danke dir :)

Super ich danke dir Smile

Dann kann ich mich ja morgen dran setzen Smile

Tappi
Habe alles hochgeladen und

Habe alles hochgeladen und bin der Anleitung gefolgt bis zum setup

Beim ausführen bekam ich nun folgende Meldung:

 

Warnung:
groupvariable 'a_can_ct_security_log' already exists.
Bitte notiere Dir die Warnungen.

Frank
Bild des Benutzers Frank
Die Meldung besagt das diese

Die Meldung besagt das diese Variable bereits existiert. Das Setup hat da diverse Möglichkeiten vom kompletten löschen und neu einlesen. Oder hat sich das inzwischen selbst erledigt?

Tappi
Das Setup war mit dieser

Das Setup war mit dieser Meldung beendet, mehr kam da nicht, aber es scheint alles zu funktionieren. IM ACP geht alles und im Portal unten bekomme ich auch angezeigt wieviel Borad Blocks und so

Frank
Bild des Benutzers Frank
Ah. Oki dann schaue ich mal

Ah. Oki dann schaue ich mal wieso dieser Hinweis dann trotzdem kommt. Thx für die Info.

Gnom
Hallo Frank

Hallo Frank

 

Hab die Tage mein Forum NEU gemacht dabei auch einige games eingebaut

 

Bei dem Backgammon habe ich im header folgende meldung

Notice: Undefined variable: chost in /var/www/webx/html/xx/ct_blocker.php on line 264

Notice: Undefined variable: chost in /var/www/webx/html/xx/ct_blocker.php on line 264

Notice: Undefined variable: chost in /var/www/webx/html/xx/ct_blocker.php on line 264

Notice: Undefined variable: chost in /var/www/webx/html/xx/ct_blocker.php on line 264

 

die datei sagt

foreach($whitehostlist as $whitehostlistvalue) { if(strpos($chost,$whitehostlistvalue) !== false){$whitehost = 1;}}

 

habe die backgammon.php mal testweise in die whitelist gepackt bringt aber auch keinen erfolg hast du noch eine idee ?

 

Gruß

Christoph

Frank
Bild des Benutzers Frank
Probiere jetzt noch mal..

Probiere jetzt noch mal..

Gnom
Notice: Undefined variable:

Notice: Undefined variable: chost in /var/www/web1/html/xx/ct_blocker.php on line 264

 

leider immernoch

Frank
Bild des Benutzers Frank
Ich war im falschen Ordner zu

Ich war im falschen Ordner zu Gange. Bitte noch mal testen.. blush

Gnom
leider immer noch :(

leider immer noch Sad

 

das betreffende forum ist im ordner wbb2neu 

Frank
Bild des Benutzers Frank
Das alte Spiel mit der

Das alte Spiel mit der Backgammon. wink Und jetzt?

Gnom
leider immer noch

leider immer noch

Frank
Bild des Benutzers Frank
Auf ein neues..

Auf ein neues.. yes

 

Kein Wunder das die Änderungen nicht angenommen wurden. Läuft ja ein Cache Modul bei Dir. Mehr dann später per PN. Teste jetzt noch mal, dürfe eigentlich nichts mehr kommen.

Gnom
jep ist weg :)

jep ist weg Smile

muss ich was beobachten wenn ich morgen auf die neue CT version update

Frank
Bild des Benutzers Frank
Eigentlich sollte dann nichts

Eigentlich sollte dann nichts gemeldet werden, wenn doch kurze Nachricht, dann sage ich dir die Änderung.

Micha
Hi,

Hi,

 

habe heute ne Meldung gefunden, gleich 2 mal:

 

1: [11-May-2012 19:22:53] PHP Notice: Undefined variable: infoblock_proxy_head in
/var/www/vhosts/michastechonline.de/httpdocs/acp/ct_blocker.php on line 245

 

Was nun?

 

Mfg,

Micha.

 

Micha
Ich weiß ja, daß die 9.3.1

Ich weiß ja, daß die 9.3.1 nicht mehr so neu ist, aber ein Update kann ich mir im Moment nicht leisten und hoffe, daß ich dennoch Hilfe bekomme. Mein Meldung vom 11.5. ist ja auch noch offen.

 

Aber ich habe gestern noch was entdeckt. Sad Wenn ich die empfohlenen Einträge in die htaccess packe und ich mich in Votinglisten Eintragen will, meldet der Folgenden Fehler:

 

Fehler: Fehler in der Webseiten-URL
Zu der URL "http://www.michastechonline.de" meldet der Server: "403 Forbidden ".
Bitte gehen Sie zurück um das Problem zu beheben.

Passiert bei den top100list.de und andere, wenn ich die Einträge in der htaccess raus nehme, klappen die Einträge.

 

Was nun?

 

mfg,

Micha.

 

Frank
Bild des Benutzers Frank
Dann würde ich da ganz

Dann würde ich da ganz schnell die Votinglisten vergessen.

 

1. Bringen die sowieso nichts, außer Abstrafungen und ...

2. Erkennt man daran gleich, das hier die Sicherheit wunderbar funktioniert.

 

Zu dem o.g. Problem, das wird einfach behoben in dem man die acp/ct_blocker.php öffnet und nach $infoblock_proxy_head sucht. DAVOR setzt man ein @. Also direkt vor dem $-Zeichen.

Micha
Hi,

Hi,

 

Ich habe Cyberstar mal gefragt, er hat die Probleme ja auch nicht mit den Votinglisten, daher irretiert mich das. Aber ich werde htaccess dann wieder füllen.

 

zu dem acp/ct_blocker.php, in Zeile 181 gibt es $infoblock_proxy_head, aber an anderen stellen auch. Muß ich die überall ändern?

 

mfg,

Micha.

 

Frank
Bild des Benutzers Frank
Nein, nur da :)

Nein, nur da Smile

Micha
Ok,

Ok,

 

habe das in Zeile 245 geändert gehabt. Der Fehler kam auch bei $infoblock_proxy, müßte ich dort dann auch so machen oder?

 

mfg,

Micha.

 

Frank
Bild des Benutzers Frank
Jupps, da dann auch.

Jupps, da dann auch.

Micha
Oki danke mache ich sofort,

Oki danke mache ich sofort, jetzt habe ich dann nur noch das Problem, daß die Fehler nicht geloggt werden. .(

 

Da wäre ich über Hilfe Massiv dankbar.

 

mfg,

Micha.

 

Frank
Bild des Benutzers Frank
Schwierig. Da ich wie gesagt

Schwierig. Da ich wie gesagt die Version nicht kenne und somit nicht weiß was da so alles an Dateien vorhanden ist und wie diese aussehen. Man kann sowas nur eingrenzen in dem man die besagte Datei genau studiert und schaut, welche anderen Dateien werden um 0 Uhr ausgelöst und dann schaut man sich diese an.

Micha
Hi,

Hi,

 

habe mit require_once den Fehler ja erstmal beseitigt, aber was mich stört, daß der keine Fehler loggt.

 

Ich habe mal ein Ticket erstellt, evtl. findest du ja was. In der phpinfo ist doch soweit alles richtig und meine zusätzlichen Daten in der htaccess ja auch.

 

Würde mich freuen, wenn du mal schauen könntest.

 

Mit der xfunctions.php hat es ja auch nichts unbedingt zu tun, hate ja auch eine Fehlerhafte php hochgeladen und ausgeführt, weiße Seite aber kein Log Eintrag in der error_log. Sad

 

mfg,

Micha.

 

Frank
Bild des Benutzers Frank
Wenn Du mit require_once das

Wenn Du mit require_once das Problem gelöst hast, dann sagt das ja schon das Problem aus. require_once bedeutet, das damit die Funktion, wenn schon vorhanden nicht noch mal versucht wird einzulesen. Leider wird noch zu include bzw. require nur genutzt anstelle von include_once bzw. require_once. Es gibt zwar Fälle wo man tatsächlich ohne _once arbeiten muss, allerdings ist das sehr selten der Fall.

 

Zum Thema mit dem Log bzw. nicht Log. Hier kann Dir nur der Hoster helfen. Frage diesen doch einfach mal, was möglich ist. smiley

Micha
Hallo,

Hallo,

 

ok, hauptsache es geht erstmal so. Smile Was das logging angeht, ich habe den Hoster mal angeschrieben ob evtl. die Fehler unterdrückt werden oder was auch immer.

 

Laut der phpinfo ist ja alles richtig, log_errors auf On, der Pfad stimmt auch.

 

Hattest dir die info ja angeschaut.

 

mfg,

Micha.

 

Micha
Hi Frank,

Hi Frank,

 

von meinem Hoster habe ich Folgende Antwort bekommen:

 

Hallo,

error_reporting  wurde wie von Ihnen gewünscht eingetragen.

Viele Grüße

 

Also wenn alles richtig Eingestellt ist, muß es doch noch einen anderen Grund geben, warum der die Fehler nicht loggt, Könntest du nicht mal schauen bitte?

 

mfg,

Micha.

 

Benutzeranmeldung

Um automatisierten Spam vorzubeugen lassen Sie dieses Feld leer.

Counter

  • Site Counter:1,412,022
  • Besucher:
    • Heute:131
    • Woche:11,752
    • Monat:30,017

Social