Daniela und Frank Leyhe GbR
Alte Hellersdorfer Straße 141
Berlin
Germany / Berlin / Berlin 12629
Phone: +49 (0)30 889 454 24

Immer 127.0.0.1 in den Protokollen

Immer 127.0.0.1 in den Protokollen

12 Beiträge / 0 neu
Letzter Beitrag
tueffel
Immer 127.0.0.1 in den Protokollen

Hallo,

Frage: Woran kann es liegen, das vom CT 9.5 bei allen Blockmeldungen immer die IP 127.0.0.1 protokolliert wird? Useragent u.s.w. passen, nur die IP stimmt nicht.

Liegt das am CT oder ist es vielleicht der Server (Ubuntu)?

LG

 

Tueffel

 

Frank
Bild des Benutzers Frank
Das kenne ich nur von Local

Das kenne ich nur von Local Installationen. Da kommt ja jeder Zugriff über diese 127.0.0.1. Local ist gemeint wenn man eine Serverumgebung auf den PC installiert hat.

 

Eine weitere Variante wäre wenn Scripte ihre IP Faken und dann als Localhost kommen.

 

Mit Ubuntu hat das eigentlich nichts zu tun, außer wie gesagt es wäre eine Locale Umgebung auf dem heimischen PC.

tueffel
Ich fasse mal zusammen...

Ich fasse mal zusammen...

Hängt vermutlich mit unserem Serverumzug zusammen. Vor dem Umzug wurden die IPs korrekt angezeigt .

Seit dem Umzug stimmt die Anzeige nicht mehr bei:

1. Den Logs des CT

2. Dem Active Bot von Alfie

Da wurde früher immer die Server IP bei den aktiven Bots angezeigt. Seit unserem Serverumzug haben die Bots halt auch 127.0.0.1 als IP.

Ist so besehen nicht unbedingt dein Problem, aber vielleicht häuft sich diese Problematik ja.

Frank
Bild des Benutzers Frank
Wurde dort der Server

Wurde dort der Server umgestellt auf Anonym? Es gibt so eine Änderungsmöglichkeit. Müsste man beim Hoster mal anfragen.

tueffel
Also wenn ich das richtig

Also wenn ich das richtig verstanden habe, dann läuft auf meinem Server ein Proxy.

Nginx nennt sich das.

Ist Bestandteil von Plesk 11.

Hab mal im Plesk nachgesehen... da läuft tatsächlich ein Dienst "nginx"

Was passiert eigentlich, wenn ich diesen Dienst im Plesk stoppe?

Frank
Bild des Benutzers Frank
Ah nginx. Normal setzt man

Ah nginx. Normal setzt man nginx vor den Apachen. Hat viele Vorteile. Da hier alle Anfragen erst an nginx gehen und dann zum Apachen durchgereicht werden. Damit kann man u.a. Anfälligkeiten vom Apachen umgehen. Nachteil kann dann allerdings auch das was Du hast sein.

 

Es gibt da dann wieder Möglichkeiten z.b. nur Gäste auf nginx zu schicken und User dann auf den Apachen usw.

 

Wenn ein Server so eingerichtet wurde und man stoppt nginx dann wird man deine Seite nicht mehr erreichen können. Da die Conf. von nginx ja nicht mehr direkt zugreifbar ist. Um das komplett umzustellen müsste man alle Domains dann auch entsprechend umstellen. Per Plesk habe ich da noch keine Automatik gefunden. Kenne daher nur den Weg über die vHosts oder wie bei Plesk es heisst die httpd_include zu ändern.

 

So ähnlich funktioniert auch varnish Cache. Weiterer Vorteil ist übrigens auch das bei nginx die Slowloris Attacken abgewehrt werden können. Ob das wirklich so ist, kann ich selber nicht sagen, aber in den vielen Beiträgen zu diesem Thema deutet es sehr darauf hin. Slowloris habe ich hier im Forum vorhin ein Beitrag geschrieben. Ich nutze hier allerdings andere Techniken.

tueffel
Vielleicht ginge ja, den

Vielleicht ginge ja, den Dienst im Plesk stoppen und dann einfach die Hostingeinstellung jeder Domain noch mal abspeichern. Dann müßte es eigentlich passen...

Oder aber, alle Domains löschen, den Dienst stoppen und dann alle Domains noch mal anlegen. Müsste auch gehen.

Aber ich sehe das als zusätzliches Sicherheitsfeature. Deswegen lasse ich den Dienst eingeschaltet.

Frank
Bild des Benutzers Frank
Würde ich auch so machen,

Würde ich auch so machen, wenn es läuft.

 

Schalte dann einfach bei CT den IP Schutz ab. Host Schutz ist damit dann auch hinfällig. Alles andere kann bleiben. Hier greift ja nginx schon einiges ab. smiley

tueffel
127.0.0.1 ist ja ein

127.0.0.1 ist ja ein Standardeintrag in der Blacklist. Sollte ich den nicht entfernen?

Frank
Bild des Benutzers Frank
Ändere den um in 127.0.0.9 ,

Ändere den um in 127.0.0.9 smiley, weil ein Eintrag wird dort benötigt.

tueffel
Ich glaube, ich hab da was

Ich glaube, ich hab da was gefunden.

Wenn ich in den entsprechenden CT-Dateien das

['REMOTE_ADDR']

gegen ein

['HTTP_X_REAL_IP']

tausche, dann werden die IP´s wieder korrekt protokolliert.

 

LG

 

Tueffel

 

 

Frank
Bild des Benutzers Frank
Okay, danke.

Okay, danke. smiley

 

Dann habe ich dafür eine schicke Lösung, die für alle dann genutzt werden kann.

Benutzeranmeldung

Um automatisierten Spam vorzubeugen lassen Sie dieses Feld leer.

Counter

  • Site Counter:1,481,608
  • Besucher:
    • Heute:489
    • Woche:2,780
    • Monat:13,397

Social